استخدام عدة برامج في Windows

آخر تحديث: مارس 19, 2021
أنت تتصفح:
الوقت المُقدر للقراءة: 6 دقيقة

تعدد البرامج في Windows

عند استخدام الكمبيوتر في إنجاز الأعمال اليومية المختلفة، تلجأ إلى استخدام البرامج المتخصصة التي تقوم بتنفيذ مهام محددة. وهذه البرامج قد تتضمن قدرات مثل معالجة النصوص، أو جداول البيانات، أو قواعد البيانات، أو التصميم الرسومي. ولا بد من تركيب هذه البرامج في الكمبيوتر بشكل مستقل، فهي لا تأتي مع Windows. لكن هذا الأخير يقدم أساسًا وأرضية للبيئة التي يمكن أن تعمل فيها تلك البرامج. ومن خلال هذه البيئة يمكنك تشغيل أي برنامج في أي وقت، كما يمكنك استخدام عدة برامج في ويندوز Windows والتبديل بين عدة برامج أثناء تشغيلها بالفعل، علاوة على أنه بإمكانك حتى مشاركة المعلومات بين البرامج المختلفة عن طريق النسخ واللصق أو عن طريق تضمين نسخة عن كائن.

التبديل بين عدة برامج مفتوحة في ويندوز Windows

عند العمل على طاولة مكتب واقعي، يتجمّع أمامك أحيانًا عدة مستندات أو مجلدات مشاريع في وقت واحد. وعندما تكون بصدد العمل على أحد المشارع، تعلم أنك تستطيع تناول مشروع آخر على مكتبك والرجوع إليه بسهولة.

وبشكل مماثل، يمكنك استخدام Windows لإبقاء عدة برامج مفتوحة في نفس الوقت مع إمكانية استخدام عدة برامج في ويندوز Windows والتبديل بين البرامج المختلفة، بحيث يكون كل واحد منها مشتغلاً ضمن إطاره الخاص على سطح المكتب. وفي الوقت الذي يكون فيه أحد البرامج ناشطًا على الدوام وظاهرًا فوق الإطارات الأخرى، يمكنك دائمًا الانتقال إلى أي إطار آخر والعمل فيه.

افترض أنك أنشأت رسمًا في برنامج الرسّام وتحتاج إلى كتابة مذكّرة لترفقها مع الرسم. وأثناء كتابة المذكّرة، تجد أنه لا بد من أن تقوم بإجراء بعض الحسابات. يمكنك التبديل بين برنامج الرسّام وبرنامج الدفتر وبرنامج الحاسبة عن طريق شريط المهام لإنجاز المهمة كما يلي:

  1. انقر زر “ابدأ”، ثم ضع المؤشر على خيار “البرامج”، ثم على خيار “البرامج الملحقة”، ومن ثم انقر خيار “الرسّام”.
  2. في قائمة “ملف”، انقر خيار “فتح”. يظهر مربع الحوار “فتح”.
  3. في مربع السرد “بحث في”، انقر نقرًا مزدوجًا خيار “جهاز الكمبيوتر” My Computer، ومن ثم انقر نقرًا مزدوجًا رمز القرص الثابت C:. تظهر محتويات القرص الثابت.
  4. انقر نقرًا مزدوجًا مجلد “المستندات” My Documents، استخدم شريط التمرير إذا لزم الأمر. تظهر محتويات المجلد المذكور.
  5. انقر نقرًا مزدوجًا ملف الرسم Pecture1. (الذي تم التطرق إليه في موضوع برنامج الرسام). يفتح رسم Pecture1 في إطار الرسّام.
  6. انقر زر “ابدأ” Start لفتح قائمة بدء التشغيل من جديد، وضع المؤشر على خيار “البرامج”، ثم على خيار “البرامج الملحقة”، ومن ثم انقر خيار “الدفتر”.
  7. في إطار برنامج الدفتر، اكتب الملاحظة التالية:

إلى: شركة الدعاية والإعلان

من: مصطفى عبيد

أرسل لكم هذا الرسم وهو يمثل الشعار الجديد للمنتج الذي نحن بصدد توزيعه عما قريب.

برجاء تصميم شعار لهذا المنتج بحيث تكون فكرته كما في الرسم المرفق.

مرسل لكم شيكًا بقيمة

استخدام الآلة الحاسبة مع الدفتر

والآن تحتاج إلى احتساب المبلغ، وذلك يتطلب الانتقال إلى برنامج الحاسبة.

8. انقر زر “ابدأ” Start، وضع المؤشر على خيار “البرامج”، ثم على “البرامج الملحقة”، ومن ثم انقر خيار “الحاسبة”.

يشتغل برنامج الحاسبة، وتظهر كل البرامج مفتوحة كما في الشكل التالي:

التبديل بين عدة برامج مفتوحة في ويندوز
التبديل بين عدة برامج مفتوحة – استخدام عدة برامج في ويندوز Windows

9. استخدم الحاسبة لتأتي بحصيلة 15% من المبلغ الإجمالي 3000. ونفذ العملية الحسابية بكتابة الأرقام والعوامل الحسابية بواسطة لوحة المفاتيح الرقمية في لوحة المفاتيح، أو بنقر الأرقام والعوامل الحسابية بواسطة الماوس على الحاسبة.

اكتب الصيغة 3000*15% مستخدماً دالة النسبة المئوية (%) في الحاسبة.

يجب أن تكون النتيجة 450.

10. في شريط المهام، انقر زر مستند – WordPad. ينشط إطار برنامج الدفتر WordPad.

11. استكمل كتابة المذكرة حيث وصلت فيها على النحو التالي:

مرسل لكم شيكا بقيمة 450 دولار، كدفعة أولى 15% من المبلغ الإجمالي.

آمل أن يتم تحديد موعد للقاء يوم الثلاثاء المقبل، لبحث الموضوع عن كثب. وشكرًا.

12. في شريط الأدوات القياسية لإطار WordPad، انقر زر الحفظ.

يظهر مربع الحوار “حفظ”. وتأكد من تحديد القرص الثابت C: ومجلد “المستندات” My Documents.

13. انقر نقرًا مزدوجًا على محتويات المربع “اسم الملف”، واكتب Letter1، ومن ثم انقر زر “حفظ”.

يتم حفظ المذكرة في القرص الثابت.

التبديل بين البرامج عبر لوحة المفاتيح

مثلما تنتقل إلى برنامج آخر بنقر اسمه في شريط المهام، يمكنك التبديل بين البرامج عبر لوحة المفاتيح.

للانتقال بين برنامج الرسّام والدفتر والحاسبة باستخدام لوحة المفاتيح:

1. فيما لا يزال إطار برنامج الدفتر ناشطاً، اضغط مفتاح ALT بشكل مستمر واضغط مفتاح TAB. ولا تفلت مفتاح ALT.

يظهر مربع حوار في وسط الشاشة يحتوي على رموز تمثل كل من الإطارات المفتوحة. ويكون اسم الإطار المحدد ظاهرًا في أسفل الإطار.

2. استمر في ضغط مفتاح ALT واضغط مفتاح TAB بشكل متكرّر إلى أن يصبح رمز برنامج الرسّام مميّزًا، ومن ثم افلت مفتاح ALT.

الآن أصبح إطار برنامج الرسّام ناشطًا.

إن ضغط ALT+ESC يبدلك بين البنود المندرجة في شريط المهام تباعًا. فإذا كان الإطار (البند) المقصود مفتوحًا في الوقت الراهن، يأتي في رأس سطح المكتب. وإذا كان مصغّرًا، يمكنك تحديده بواسطة ALT+ESC ومن ثم ضغط مفتاح الإدخال ENTER لاستعادة إطاره في سطح المكتب.

المشاركة في المعلومات بين البرامج المختلفة

ربما كنت تتعامل في المستندات الورقية حيث كان كل منها يحتوي على معلومات تريد ضمّها إلى مستند آخر. ولتجنب صعوبة النسخ اليدوي، ربما كنت تستعمل المقص لقص المعلومات من مستند ومن ثم لصقها بالشريط اللاصق أو الصمغ على مستند آخر.

في Windows، يمكنك قص أو نسخ المعلومات إلكترونيًا من أحد البرامج ومن ثم لصقها في برنامج آخر كأحد طرق مشاركة المعلومات بين البرامج. على سبيل المثال، القص أو النسخ ومن ثم اللصق من برنامج الرسّام Paint إلى برنامج الدفتر WordPad، أو من برنامج Excel إلى برنامج Word.

في المثال السابق، افترض أنك تريد دمج كل من الرسم والمذكرة لترسلهما إلى شركة الدعاية والإعلان ضمن مستند واحد، الخطوات التالية توضح هذا العمل.

خطوات مشاركة المعلومات بين البرامج عن طريق النسخ واللصق

  1. انقر زر “ابدأ”، وضع المؤشر على خيار “البرامج”، ثم على “البرامج الملحقة”، ومن ثم انقر بند “الدفتر” لتشغيل البرنامج.
  2. في قائمة “ملف”، انقر خيار “فتح”.يظهر مربع الحوار “فتح”.
  3. في مربع السرد “بحث في”، انقر نقرًا مزدوجًا خيار “جهاز الكمبيوتر” My Computer، ومن ثم انقر نقرًا مزدوجًا رمز القرص الثابت C:.تظهر محتويات القرص الثابت.
  4. انقر نقرًا مزدوجًا مجلد “المستندات” My Documents، استخدم شريط التمرير إذا لزم الأمر. تظهر محتويات المجلد المذكور.
  5. انقر نقرًا مزدوجًا ملف المستند Letter. يفتح المستند المذكور.
  6. انقر زر “ابدأ” Start لفتح قائمة بدء التشغيل من جديد، وضع المؤشر على خيار “البرامج”، ثم على خيار “البرامج الملحقة”، ومن ثم انقر خيار “الرسّام”. يتم فتح البرنامج.
  7. في قائمة ملف، انقر خيار “فتح”، يظهر مربع الحوار “فتح”.
  8. في مربع السرد “بحث في”، انقر نقرًا مزدوجًا خيار “جهاز الكمبيوتر” My Computer، ومن ثم انقر نقرًا مزدوجًا رمز القرص الثابت C:.تظهر محتويات القرص الثابت.
  9. انقر نقرًا مزدوجًا مجلد “المستندات” My Documents، استخدم شريط التمرير إذا لزم الأمر. تظهر محتويات المجلد المذكور.
  10. انقر في المجلد نقرًا مزدوجًا ملف الصورة Pecture1. يفتح الملف المذكور. ثم كبّر إطار البرنامج.

النسخ من الرسّام واللصق في الدفتر

بعد فتح البرنامجين المراد تبادل المعلومات بينهما كما تم التوضيح أعلاه، يمكن إجراء عملية مشاركة المعلومات بين البرامج عن طريق النسخ واللصق كما يلي:

11. في إطار برنامج الرسّام، انقر أداة التحديد، ومن ثم اسحب مستطيل منقّط حول الرسم بأكمله.

12. في قائمة “تحرير”، لبرنامج الرسّام، انقر أمر “نسخ”.

على الرغم من أنه لا يبدو أن شيئًا قد تغيّر على الشاشة، يكون الرسم قد نُسخ بشكل مؤقت على الحافظة التي هي المكان المؤقت الذي تلجأ إليه البنود المقصوصة أو المنسوخة لحين استخدامها في عملية اللصق.

13. في شريط المهام، انقر زر Letter1 – WordPad. يظهر إطار البرنامج. قم بتكبيره.

14. انقر مكان ما في نهاية المستند، بعد كلمة (وشكراً). واضغط مفتاح الإدخال ENTER مرتين لإضافة سطرين فارغين.

15. في شريط أدوات البرنامج، انقر زر اللصق. أو انقر أمر “لصق” من قائمة تحرير.

يظهر الرسم في المذكرة كما يلي:

النسخ من الرسّام واللصق في الدفتر - مشاركة المعلومات بين البرامج - استخدام عدة برامج في ويندوز Windows
النسخ من الرسّام واللصق في الدفتر – مشاركة المعلومات بين البرامج – استخدام عدة برامج في ويندوز Windows

16. في شريط الأدوات، انقر زر الحفظ.

تحديث المعلومات المتبادلة بين البرامج

يمكنك أيضاً تحديث الرسم الذي قمت بنسخه من برنامج الرسّام ولصقه في برنامج الدفتر، وإضافة بعض التعديلات عليه، لعمل ذلك الرسم:

1. انقر نقرًا مزدوجًا الرسم الموجود في المذكرة.

يتغير شريط القوائم وشريط الأدوات في برنامج الدفتر، ويُستبدلان مؤقتًا بشريط القوائم، ومربع الأدوات، ومربع الألوان العائدة لبرنامج الرسّام.

2. قم بالتعديلات اللازمة، ثم انقر أي مكان خارج إطار الرسم (أي داخل مستند برنامج الدفتر).

تختفي أشرطة برنامج الرسّام، ويظهر شريطا القوائم والأدوات التابعان لبرنامج الدفتر من جديد.

3. في شريط الأدوات، انقر زر الحفظ.

إن التعديل الذي قمت به على الرسم الذي نسخته من برنامج الرسّام إلى برنامج الدفتر، لم يؤثر على الرسم الأصلي الموجود في برنامج الرسّام. ويمكنك التأكد من ذلك بفتح ملف الرسم المقصود في برنامج الرسّام. أما إذا استخدمت عملية “تضمين كائن”، المتاحة بين البرامج العاملة بـ Windows، فإن أي تغيير يجري على كائن مضمن في أحد البرامج، ينعكس على الكائن الأصلي الذي تم تضمين نسخة عنه.

تضمين نسخة عن كائن

يمكنك استخدام Windows لإدخال، أو تضمين نسخة عن كائن، تم إنشاؤه في برنامج آخر (المصدر) في البرنامج الحالي (المقصد).

وعند تضمين نسخة عن الكائن بهذا الأسلوب، يمكنك استخدام موارد البرنامج المصدر لتحرير الكائن المُضمن دون ترك البرنامج الذي تعمل ضمنه. الأمر الذي يضاعف الموارد ضمن مستند واحد.

ولكن تحديث الكائن المضمن سوف ينعكس على الكائن المصدر تلقائيًا في هذه الحالة.

مثال تضمين نسخة عن كائن من الرسام إلى الدفتر

فيما يلي خطوات تضمين تسخة عن كائن من برنامج الرسام إلى برنامج الدفتر:

1. انقر زر “ابدأ” Start، وضع المؤشر على خيار “البرامج” Programs، ثم على “البرامج الملحقة”، ومن ثم انقر بند “الدفتر” لتشغيل البرنامج. يتم تشغيل البرنامج وعرض مستند جديد.

2. في قائمة إدراج، انقر أمر “كائن”.

يظهر مربع الحوار “إدراج كائن” Insert Object حيث يكون خيار “إنشاء جديد” محددًا.

تضمين نسخة عن كائن
تضمين نسخة عن كائن

3. انقر خانة الاختيار “إنشاء من ملف”، لتحديد هذا الخيار.

يتغير شكل مربع الحوار، ليصبح بإمكانك من خلاله استعراض الملفات وتحديد أحدها لتضمينه ككائن منفصل في المستند الحالي.

4. انقر زر “استعراض”.

يظهر مربع حوار “استعراض”. تأكد فيه من تحديد رمز القرص الثابت C: ومجلد “المستندات” My Documents كموقع للملف في مربع نص “بحث في”.

5. انقر اسم ملف الصورة المطلوب تضمينها وهو Pecture1. ومن ثم انقر زر “إدراج”.

يظهر مربع الحوار “إدراج كائن” من جديد، حيث يكون ملف الصورة ومساره مكتوبًا داخل مربع النص “ملف”.

6. في مربع الحوار “إدراج كائن” انقر خيار “ارتباط” ليصبح محددًا.

إذا قمت بتحديد هذا الخيار، فسوف تلاخظ أن التغييرات التي تجريها تنعكس على الصورة في الملف المصدر.

6. في مربع الحوار “إدراج كائن”، انقر زر “موافق”.

يظهر الرسم في المستند الجديد.

7. انقر نقرًا مزدوجًا الرسم الموجود في المستند.

يتم فتح برنامج الرسام، ويظهر إطاره ليصبح أمام إطار برنامج الدفتر، يمكنك استخدام إطار البرنامج والرسم الموجود به لإجراء التعديلات، بعد ذلك سوف ترى التعديلات على الرسم المضمن في مستند برنامج الدفتر تلقائيًا.

8. بعد إتمام التعديلات المطلوبة، قم بإغلاق برنامج الرسّام. وانقر زر الحفظ إذا أردت حفظ التغيير.

عرض كل موضوعات نظام التشغيل مايكروسوفت ويندوز Microsoft Windows في مركز المساعدة أو المراجع التعليمية

مركز المساعدة – المراجع التعليمية – مركز البحوث والدراسات متعدد التخصصات

المصدر

  • كتاب: مقدمة في الكمبيوتر ونظام التشغيل ويندوز Windows، مصطفى عبيد، فلسطين، 1998م.
هل كان الموضوع مفيدًا؟
لا 0
المشاهدات: 87

الاستمرار في القراءة

السابق: رسم الصور مع برنامج الرسام Paint