البحث والاستبدال والعرض والطباعة في SPSS

آخر تحديث: مارس 24, 2021
أنت تتصفح:
الوقت المُقدر للقراءة: 4 دقيقة

عمليات البحث والاستبدال في SPSS

في محرر البيانات، يمكنك إجراء عمليات البحث والاستبدال للبيانات في SPSS. كما يمكن إجراء البحث والاستبدال لكل من الحالات والمتغيرات والافتراضات، وكذلك قيم السمات، وطباعة محرر البيانات وغيرها من العمليات في SPSS.

إيجاد الحالات أو المتغيرات أو الافتراضات

يبحث مربع الحوار Go To عن رقم الحالة (الصف) المحدد أو اسم المتغير في محرر البيانات في SPSS.

الحالات

  1. للحالات، اختر من القوائم: تحرير> انتقال إلى الحالة
  2. أدخل قيمة عدد صحيح يمثل رقم الصف الحالي في طريقة عرض البيانات.

ملاحظة: يمكن أن يتغير رقم الصف الحالي لحالة معينة بسبب الفرز والإجراءات الأخرى.

المتغيرات

  1. للمتغيرات، اختر من القوائم: تحرير> انتقل إلى متغير …
  2. أدخل اسم المتغير أو حدد المتغير من القائمة المنسدلة.

الاقتراحات

تتطلب هذه الميزة خيار القيم المفقودة، والخطوات كما يلي:

  1. اختر من القوائم: تحرير> الذهاب إلى الاقتراب …
  2. حدد التضمين (أو البيانات الأصلية) من القائمة المنسدلة.

بدلاً من ذلك، يمكنك تحديد التضمين من القائمة المنسدلة في شريط التحرير في طريقة عرض البيانات لمحرر البيانات.

يتم الحفاظ على موضع الحالة النسبية عند اختيار الافتراضات. على سبيل المثال، في حالة وجود 1000 حالة في مجموعة البيانات الأصلية، يتم عرض الحالة 1034، الحالة 34 في التضمين الأول، أعلى الشبكة. إذا حددت التضمين 2 في القائمة المنسدلة، فستظهر الحالة 2034، الحالة 34 في التضمين 2، في أعلى الشبكة. إذا قمت بتحديد البيانات الأصلية في القائمة المنسدلة، فسيتم عرض الحالة 34 في أعلى الشبكة. يتم أيضًا الحفاظ على موضع العمود عند التنقل بين الافتراضات، بحيث يسهل مقارنة القيم بين الافتراضات.

البحث عن البيانات وقيم السمات واستبدالها في SPSS

للبحث عن قيم البيانات و/ أو استبدالها في طريقة عرض البيانات أو قيم السمات في طريقة عرض المتغير في SPSS:

  1. انقر فوق خلية في العمود الذي تريد البحث فيه. (البحث عن القيم واستبدالها مقيد بعمود واحد).
  2. اختر من القوائم: تحرير> بحث
  3. أو اختر: تحرير> استبدال

عرض البيانات

لا يمكنك البحث للأعلى في طريقة عرض البيانات. اتجاه البحث دائما لأسفل.

بالنسبة للتواريخ والأوقات، يتم البحث في القيم المنسقة كما هي معروضة في طريقة عرض البيانات. على سبيل المثال، التاريخ المعروض في 10/28/2007 لن يتم العثور عليه بواسطة البحث عن تاريخ 10-28-2007.

للمتغيرات الرقمية الأخرى، يحتوي على ويبدأ بـ وينتهي بقيم البحث المنسقة. على سبيل المثال، مع خيار يبدأ بـ، ستجد قيمة البحث 123 دولارًا لمتغير تنسيق الدولار كلاً من 123.00 دولارًا و 123.40 دولارًا ولكن ليس 1234 دولارًا. باستخدام خيار الخلية بأكملها، يمكن تنسيق قيمة البحث أو عدم تنسيقها (تنسيق رقمي بسيط F)، ولكن يتم مطابقة القيم الرقمية الدقيقة فقط (للدقة المعروضة في محرر البيانات).

يتم تمثيل القيمة الرقمية المفقودة في النظام بنقطة واحدة (.) للعثور على القيم المفقودة في النظام، أدخل فترة واحدة كقيمة البحث وحدد الخلية بأكملها.

إذا تم عرض تسميات القيم لعمود المتغير المحدد، فسيتم البحث في نص التسمية، وليس قيمة البيانات الأساسية، ولا يمكنك استبدال نص التسمية.

عرض متغير

  • البحث متاح فقط لأعمدة سمات الاسم والتسمية والقيم والمفقود والمتغير المخصص.
  • استبدال متاح فقط لأعمدة التسمية والقيم والسمات المخصصة.
  • في عمود القيم (تسميات القيمة)، يمكن أن تطابق سلسلة البحث إما قيمة البيانات أو تسمية القيمة.

ملاحظة: سيؤدي استبدال قيمة البيانات إلى حذف أي تسمية قيمة سابقة مرتبطة بهذه القيمة

الحصول على إحصائيات وصفية لمتغيرات مختارة

للحصول على إحصائيات وصفية للمتغيرات المحددة:

  1. انقر بزر الماوس الأيمن فوق المتغيرات المحددة في طريقة عرض البيانات أو طريقة عرض المتغير.
  2. من القائمة المنبثقة، حدد الإحصاء الوصفي Descriptive Statistics.

بشكل افتراضي، يتم عرض جداول التكرار (جداول الأعداد) لجميع المتغيرات ذات القيم الفريدة 24 أو أقل. يتم تحديد الإحصائيات الموجزة حسب مستوى القياس للمتغير ونوع البيانات (عددي أو سلسلة):

  • سلسلة String: لا يتم احتساب إحصائيات موجزة لمتغيرات السلسلة.
  • مستوى قياس عددي أو اسمي أو غير معروف: المدى، الحد الأدنى، الحد الأقصى، الوضع.
  • لمستوى القياس الرقمي والترتيبي: المدى، الحد الأدنى، الحد الأقصى، الوضع، المتوسط، الوسيط.
  • مستوى قياس رقمي ومستمر: المدى، الحد الأدنى، الحد الأقصى، الوضع، المتوسط، المتوسط، الانحراف المعياري.

يمكنك أيضًا الحصول على مخططات شريطية للمتغيرات الاسمية والترتيبية، ورسوم بيانية للمتغيرات المستمرة (مقياس)، وتغيير قيمة القطع التي تحدد وقت عرض جداول التردد. راجع موضوع خيارات الإخراج لمزيد من المعلومات.

اختيار الحالة (السجل) في محرر البيانات

إذا كنت قد حددت مجموعة فرعية من الحالات ولكنك لم تتجاهل الحالات غير المحددة، فسيتم تمييز الحالات غير المحددة في محرر البيانات بخط قطري (شرطة مائلة) عبر رقم الصف.

خيارات عرض محرر البيانات

توفر قائمة العرض عدة خيارات عرض لمحرر البيانات:

  • الخطوط: يتحكم هذا الخيار في خصائص خط عرض البيانات.
  • خطوط الشبكة: يقوم هذا الخيار بتبديل عرض خطوط الشبكة.
  • تسميات القيمة: يقوم هذا الخيار بالتبديل بين عرض قيم البيانات الفعلية وتسميات القيم الوصفية المعرفة من قبل المستخدم. هذا الخيار متاح فقط في طريقة عرض البيانات.

باستخدام طرق عرض متعددة

في “طريقة عرض البيانات”، يمكنك إنشاء طرق عرض (أجزاء) متعددة باستخدام المقسمات الموجودة أسفل شريط التمرير الأفقي وعلى يمين شريط التمرير العمودي.

يمكنك أيضًا استخدام قائمة Window لإدراج مقسمات الألواح وإزالتها. لإدخال المقسمات:

  1. في طريقة عرض البيانات، اختر من القوائم: نافذة> انقسام

يتم إدراج المقسمات أعلى وإلى يسار الخلية المحددة.

  • إذا تم تحديد الخلية اليسرى العلوية، فسيتم إدراج المقسمات لتقسيم العرض الحالي إلى النصف تقريبًا، أفقيًا وعموديًا.
  • أما إذا تم تحديد أي خلية غير الخلية العلوية في العمود الأول، فسيتم إدراج مقسم الجزء الأفقي أعلى الخلية المحددة.
  • وإذا تم تحديد أي خلية غير الخلية الأولى في الصف العلوي، فسيتم إدراج مقسم الجزء العمودي إلى يسار الخلية المحددة.

تشغيل التحويلات المعلقة

انقر فوق “موافق” في مربع الحوار لتشغيل أي تحويلات معلقة. يمكنك بعد ذلك إدخال البيانات أو تحريرها في محرر البيانات.

انقر فوق “لا” إذا كنت لا تريد تشغيل عمليات التحويل المعلقة. إذا كانت لديك تحويلات معلقة، فستتلقى تحذيرًا في المرة الأولى التي تحاول فيها تحرير البيانات في محرر البيانات. يمكنك بعد ذلك تحرير البيانات في محرر البيانات، ولكن قد يتم فقد تغييراتك عند تشغيل التحويلات المعلقة (حسب طبيعة التحويلات).

لتجنب التحولات المعلقة:

  1. اختر من القوائم: تحرير> خيارات
  2. انقر فوق علامة التبويب البيانات.
  3. حدد حساب القيم على الفور.

طباعة محرر البيانات

  • تتم طباعة ملف البيانات كما يظهر على الشاشة.
  • تتم طباعة المعلومات الموجودة في العرض المعروض حاليًا. في طريقة عرض البيانات، تتم طباعة البيانات. في طريقة العرض المتغيرة، تتم طباعة معلومات تعريف البيانات.
  • تتم طباعة خطوط الشبكة إذا كانت معروضة حاليًا في طريقة العرض المحددة.
  • تُطبع ملصقات القيمة في طريقة عرض البيانات إذا كانت معروضة حاليًا. خلاف ذلك، يتم طباعة قيم البيانات الفعلية.
  • استخدم قائمة العرض في نافذة محرر البيانات لعرض خطوط الشبكة أو إخفائها والتبديل بين عرض قيم البيانات وتسميات القيم.

خطوات طباعة محتويات محرر البيانات

  1. اجعل محرر البيانات النافذة النشطة.
  2. انقر فوق علامة التبويب الخاصة بطريقة العرض التي تريد طباعتها.
  3. اختر من القوائم: ملف> طباعة ..

المصدر

  • المرجع الأساسي لبرنامج التحليل الإحصائي SPSS، ترجمة وإعداد: د. م. مصطفى عبيد، مركز البحوث والدراسات متعدد التخصصات.
  • الموقع الرسمي لشركة آي بي إم IBM SPSS software.

عرض كل موضوعات المرجع الأساسي لبرنامج التحليل الإحصائي SPSS في مركز المساعدة أو المراجع التعليمية

مركز المساعدة – المراجع التعليمية – مركز البحوث والدراسات متعدد التخصصات – MDRS CENTER
البحث والاستبدال وعرض وطباعة محرر البيانات في SPSS
البحث والاستبدال وعرض وطباعة محرر البيانات في SPSS
هل كان الموضوع مفيدًا؟
لا 0
المشاهدات: 197

الاستمرار في القراءة

السابق: تحرير البيانات في SPSS
التالي: طريقة عرض المتغير في SPSS